設定ファイルは、現在の秘密のパスフレーズ(blowfish_secret)が必要[phpMyAdminのを修正]

インストールしたかどうかphpMyAdminの サーバー Ubuntuの, CentOSの またはなど フェドーラ 配布、メッセージ "設定ファイルは現在、秘密のパスフレーズ(blowfish_secret)が必要「インデックスの、手間の下部にある赤で。 それが「で正しく設定されている場合は特に/etc/phpMyAdmin/config.inc.php"。
もちろん、パスは、別の構成によって異なるが、できます 7 CentOSの cu phpMyAdminの "経由でインストールyum「中」remi.repoの/ etc / phpMyAdminは/」「設定ファイルは次の場所にあります」。

グッド、「あなたはどのように処理するかを見てみましょう設定ファイルは現在、秘密のパスフレーズ(blowfish_secret)が必要「もしconfig.inc.phpを 我々は、このラインを持っています:

$ CFG [ 'blowfish_secret'] = '$ gNsWq $%#%#%EDFSsffsegbVp6LCJw6w'; / *クッキーのAUTHのためにこれを入力する必要があります! * /

この行が存在し、私たちは、phpMyAdminの赤いメッセージに32文字の上に「キー」を持っている場合は消えるはずです。
これは実現しなかった場合は、あなたのブラウザからクッキーを削除し、phpMyAdminのからログアウトする必要があります。 次回のログイン時に、メッセージ "設定ファイルは現在、秘密のパスフレーズ(blowfish_secret)が必要「私は存在しません。
それが存在する状況ではありますが 設定ミスによるものではありません config.inc.phpファイルですが、 彼がいたフォルダのアクセス許可.

ターミナルコマンドラインで実行します。

 chownコマンド-Rルート:nginxのは/ etc / phpMyAdminは/

今はすべてがうまくいくはずです。 ユーザー:nginxではなくApacheを使用する場合は、サーバー上でWebプロセスのユーザーを持つ方法、または「httpd」を設定します。

私はphpMyAdminのコンフィグ全体2の時間にわたってスピンし、まだメッセージを免れることはできないので、私はこのヒントを書いた:設定ファイルは現在、秘密のパスフレーズ(blowfish_secret)が必要です。 解決の許可/グループの後、姿を消しました。

設定ファイルは、現在の秘密のパスフレーズ(blowfish_secret)が必要[phpMyAdminのを修正]

著者について

ステルスLP

創設者兼編集者 ステルス設定2006日で。
Linuxオペレーティングシステム(特にCentOSの)やMac OS X、Windows XPの>は、Windows 10とワードプレス(CMS)上の経験。

コメントを残す

このサイトはAkismetを使用して迷惑メールを減らします。 コメントの処理方法を学ぶ.